В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу нахождения суммы чисел от 1 до 20 с использованием цикла с предусловием и постусловием

Показать ответ
Ответ:
Ghhgfgh
Ghhgfgh
02.02.2022 01:19
Значит так: мы создаем массив избыточной длины, куда потом будем записывать рандомные числа. Так же мы создаем массив-счетчик b (у него индексами являются сами числа, а элементами - количество этого числа в массиве А), куда будет присваиваться, сколько раз нам встречается то или иное число (перед этим мы массив обязательно обнулим). В конце мы смотрим максимальное число из массива-счетчика. Вуаля!

Вот пример программы на паскале ABC:

var a:array [1..1000000] of integer; 
b:array [1..10] of longint;   
c:integer;   
i,max,n:longint;
begin
write('Введите число элементов массива: ');
readln(n); 
max:=0; 
for i:=1 to 10 do 
b[i]:=0; 
for i:=1 to n do  begin 
a[i]:=random(10)+1; 
write(a[i],' '); 
b[a[i]]:=b[a[i]]+1 
end; 
for i:=1 to 10 do if b[i]>max then 
begin 
c:=i; 
max:=b[i] 
end; 
writeln; 
writeln('Чаще всего в массиве встречается число ',c)
end.
0,0(0 оценок)
Ответ:
viktoska87
viktoska87
11.04.2020 13:17
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота