В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Apelsin2403
Apelsin2403
16.04.2020 14:26 •  Информатика

Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (N больше или равно 1 и меньше или равно 1000)

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

Показать ответ
Ответ:
диана128
диана128
11.10.2020 20:40

var N,C,D,i: longint;

begin

 assign(input, 'input.txt'); reset(input);

 read(N,C,D);

 C:=C*D;

 for i:=1 to N div C do  

 if N mod (C*i) = 0 then

 write(C*i, ' ');

 writeln();

end.

Объяснение:

но эт не точно

0,0(0 оценок)
Ответ:
Anel7575
Anel7575
11.10.2020 20:40

var n,i,s:integer;

begin

read(n);

s:=0;

for i:=n downto 1 do

if n mod i = 0 then  s:=s+i;

write(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота