Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Берёза123
13.01.2021 12:20 •
Информатика
Составить программу: найти наибольшее значение функции y=ax в квадрате+bx+c на отрезке [x1,x2]
Показать ответ
Ответ:
Белоеморе
03.10.2020 17:18
Var
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
0,0
(0 оценок)
Ответ:
NikitaAadvanser
03.10.2020 17:18
Var
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
SekretKtoYa
02.02.2022 11:08
Ввести с клавиатуры число в двоичной системе счисления. Определить, сколько в его записи единиц и сколько нулей. Пример: Введите число: 1010100 Нулей: 4 Единиц: 3 переделайте...
матиматик13
17.08.2020 19:59
Кто понимает информатику, в частности , не могу понять в чём проблема. Не запускается программа...
maslennikovavi2
13.05.2021 22:44
Вязыке запросов поискового сервера для обозначения логической операции или используется символ | а для логической операции и символ & торты|пироги - 12000 страниц торты...
Chopykoe
10.02.2020 16:26
Некоторый метод шифрования текста основан на замене каждой буквы шифруемого текста на другую путем смещения в алфавите от исходной буквы на фиксированное количество символов....
sadzim
20.11.2022 21:30
Решить крассворд! 7 и 9 . 7) элемент интерфейса пользователя , позваляющий выбрать одну из нескольких опций программ.9) исследовательская лаборатория, разработавшая концепцию...
Диана19371
20.11.2022 21:30
Порівняти програму paint і inkscape...
ZigZag1983
12.12.2021 18:12
Сколько символов в тексте, если мощность алфавита равна 32 символа, а объем информации равен 1,5 кб....
angelochekbobi
12.12.2021 18:12
Для кодиравания каждой буквы слова используются двузначные числа. известно, что буква «е» закодирована числом 20. среди слов «елка», «полка», «поле», «пока», «кол», есть слова,...
vladdendi
23.09.2021 04:19
1.конституция объединенной германии была принята в… а) 1870 г.; б) 1871 г.; в) 1872 г.; г) 1873 г. 2.высшее представительное учреждение германии называлось… а) ландтаг; б)...
misa0231as0231
23.09.2021 04:19
Сравните положение городов на западе и на востоке в 16-17вв...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
y, a, b, c, x, x2, h, max: real;
begin
write('Введите a,b,c');
readln(a, b, c);
write('Введите x1,x2 и шаг');
readln(x, x2, h);
max := a * x * x + b * x + c;
repeat
y := a * x * x + b * x + c;
if max < y then max := y;
x := x + h;
until x > x2;
writeln(max);
end.
i,max,x1,x2,a,b,c:integer;
begin
read(x1,x2,a,b,c);
max:=-2147483648;
for i:=x1 to x2 do
if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
writeln(max);
end.