В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
faridremihanov1
faridremihanov1
08.04.2021 00:08 •  Информатика

Составить программу обработки данной строки, позволяющую: a) выписать все прописные буквы из данной строки в порядке их следования; b) определить, содержатся ли в тексте цифры; c) найти общее количество круглых, квадратных и фигурных скобок в тексте; d) выписать все знаки препинания из данной строки, сохранив их последовательность;

Показать ответ
Ответ:
terehovakira
terehovakira
20.06.2020 18:27
A)
var a: string;
    i: integer;
begin
     readln(a);
     for i := 1 to length(a) do
         if (a[i] <> UpCase(a[i])) then
            write(a[i], ' ');
end.

b)
var a: string;
    i, p: integer;
    q: boolean;
begin
     readln(a);
     for p := 0 to 9 do
         for i := 1 to length(a) do
             if (a[i] = inttostr(p)) then
                    q := true;
     writeln(q);
end.

c)
var a: string;
    i, p, u: integer;
    o: array [0..5] of char;
begin
     readln(a);
     o[0] := '('; o[1] := ')'; o[2] := '{'; o[3] := '}'; o[4] := '['; o[5] := ']';
     for p := 0 to 5 do
         for i := 1 to length(a) do
             if (a[i] = o[p]) then
                    u := u + 1;
     writeln(u);
end.

d)
var a: string;
    i, p: integer;
    o: array [0..7] of char;
begin
     readln(a);
     o[0] := '('; o[1] := ')'; o[2] := '?'; o[3] := '!'; o[4] := '"'; o[5] := '.'; o[6] := ','; o[7] := ',';
     for i := 1 to length(a) do
         for p := 0 to 7 do
             if (a[i] = o[p]) then
                    writeln(a[i]);
end.

Ну вот:) О, мой мозг, как же тебе досталось! ~_~
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота