В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MashaFox25
MashaFox25
17.03.2021 15:21 •  Информатика

Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М, значения которых находятся в интервале от -5 до 10 возвести в квадрат. Измененный массив вывести на экран.

Показать ответ
Ответ:
ibragimabdulaev
ibragimabdulaev
15.10.2020 14:44

arr = [int(i) for i in input().split()]

new_arr = []

for i in arr:

  if i>=-5 and i<=10:

       new_arr.append(i**2)

   else:

        new_arr.append(i)

[print(i, end=" ") for i in new_arr]

Краткий гайд:

arr -  исходный списокnew_arr - измененный список
Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота