В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lizka119
lizka119
20.07.2020 00:15 •  Информатика

Составить программу, определяющую, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, уравнения окружности, уравнения прямых, параллельных осям координат). результат работы программы вывести в виде текстового сообщения. (параметры r, r1, r2, a, b,с вводятся с клавиатуры.) - если имеются

Показать ответ
Ответ:
Ali20071011
Ali20071011
11.08.2020 17:52

отправь нарушение ошипся я не знаю

0,0(0 оценок)
Ответ:
kurzaevaelenka
kurzaevaelenka
11.08.2020 17:52

var

 x, y, r: real;

begin

 read(x, y, R);

 if (x * x + y * y <= R * R) or

   (y <= 0) and (y >= -2 * x) and (y >= 2 * (x - R)) then

   write('попадает')

 else

   write('не попадает');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота