Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше. нахождение количество цифр числа оформить в виде функции решение на паскале, написать программу
function len(a: integer): byte; begin result := Length(IntToStr(a)); end;
var a, b: integer;
begin for i: byte := 1 to 5 do //Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее begin readln(a); if (len(a) > len(b)) then b := a; end; writeln(b); end.
begin
result := Length(IntToStr(a));
end;
var
a, b: integer;
begin
for i: byte := 1 to 5 do //Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее
begin
readln(a);
if (len(a) > len(b)) then
b := a;
end;
writeln(b);
end.