В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gimnastikgirla
gimnastikgirla
29.01.2022 13:58 •  Информатика

Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программирования Pascal)

Показать ответ
Ответ:
oll5
oll5
25.01.2021 13:48

см. объяснения + скрин

Объяснение:

program prog;

var

  num,chetnoe,nechetnoe,ost :integer;

begin

writeln('Vvedite chislo:');

readln(num);

chetnoe:=0;

nechetnoe:=0;

if num=0 then chetnoe:=1 else

begin

 while (num<>0) do begin

  ost:=(num mod 10) mod 2;

  if (ost=0) then chetnoe:=chetnoe+1

  else nechetnoe:=nechetnoe+1;

  num:=num div 10;

 end;

end;

writeln('четныx = ',chetnoe);

writeln('нечетных = ',nechetnoe);

end.


Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программиров
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота