В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
katttty9989
katttty9989
25.09.2020 12:34 •  Информатика

Составить программу, определяющую, все целые числа из промежутка от 300 до 600, у которых сумма делителей кратна 10. язык: с++; ps: нужно решить при do_while

Показать ответ
Ответ:
Alexandro1888
Alexandro1888
04.10.2020 19:22

#include <iostream>

using namespace std;


int main () {

    

    int digit = 300;

    

    do {

        int sum = 0;

        int teiler = 1;

        

        while (teiler <= digit)

        {

            if (digit % teiler == 0)

                sum+=teiler;

            

            teiler++;

            

        }

        

        if(sum % 10 == 0)

        {

            cout << digit << endl;

        }

        

        digit++;

        

    } while (digit <= 600);

    

    return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота