В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Daryanaa7
Daryanaa7
05.05.2021 18:06 •  Информатика

Составить программу paskal для: 1)найти стороны прямоугольника, у которого известны периметр и площадь 2)дано трехзначное натуральное число. определить, является ли сумма его цифр двузначным числом

Показать ответ
Ответ:
Амишка51
Амишка51
26.07.2020 20:06
Pascal ABC
1)

Var P,S:real;
Begin
Write('P = ');Read(P);
Write('S = ');Read(S);
if (P/2-sqrt(P*P/4-4*S))/2<0 then S:=(P/2+sqrt(P*P/4-4*S))/2
else S:=(P/2-sqrt(P*P/4-4*S))/2;
WriteLn('Первая сторона равна ',S);
WriteLn('Вторая ',P/2-S);
End.

2)

Var
A:integer;
Begin
Write('A = ');Read(A);
if ((A div 10) mod 10) +(A mod 10)+(A div 100)>9 then Write('Является')
else Write('Не является')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота