Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Lordfantomchik
12.02.2021 22:55 •
Информатика
Составить программу паскаль которая будет вычислять периметр и площадь прямоугольника. и программу которая будет вычислять косинус углов треугольника а,в,с
Показать ответ
Ответ:
marusi220
03.10.2020 21:36
Периметр прямоугольника: P=2(a+b). Площадь: S=ab
Косинусы углов в треугольнике:
cosA=(b²+c²-a²)/(2bc); cosB=(a²+c²-b²)/(2ac); cosC=(a²+b²-c²)/(2ab)
var
a,b:real;
begin
Write('Введите a,b: ');
Read(a,b);
Write('P=',2*(a+b),', S=',a*b)
end.
Тестовое решение
Введите a,b: 12.2 8
P=40.4, S=97.6
var
a,b,c,cosA,cosB,cosC:real;
begin
Write('Введите a,b,c: ');
Read(a,b,c);
cosA:=(b*b+c*c-a*a)/(2*b*c);
cosB:=(a*a+c*c-b*b)/(2*a*c);
cosC:=(a*a+b*b-c*c)/(2*a*b);
Write('cosA=',cosA,', cosB=',cosB,', cosC=',cosC)
end.
Тестовое решение
Введите a,b,c: 15.3 8 14.2
cosA=0.138864436619718, cosB=0.855495719414526, cosC=0.393995098039216
0,0
(0 оценок)
Популярные вопросы: Информатика
плохознающия
03.11.2021 16:53
Работали в лаборатории. когда они закончили эксперимент, то должны были убрать все реагенты в сейф. чтобы открыть сейф, им нужно было нажать на каждую кнопку сейфа то количество...
BlackJuice
03.11.2021 16:53
Составе программу, которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения....
Hffjcdhudyhx
29.08.2021 00:22
Составьте программу к . вычислить сумму нечетных чисел из интервала от 30 до 50...
Domashka00
15.06.2021 18:11
Одномерный массив заполнить случайными числами. найти в непустом массиве минимальный элемент и определить его порядковый номер. подсчитать количество элементов, равных минимальному....
LiliLaind
09.05.2020 17:41
Марат разрабатывает новую обучающую компьютерную игру по математике для детей 4-11 лет.а. Напишите требования к оформлению интерфейса.b. Спроектируйте интерфейс обучающей игры....
superasmik2018
11.06.2020 11:55
6) Х равен остатку отделения 19 на 5:7) Z равен частному(целое)от деления 18 на 3:...
Макс228500
03.07.2022 23:33
1 задание из Егэ Информатика На рисунке справа схема дорог Н-ского района изображена в виде графа, в таблице содержатся сведения о длинах этих дорог (в километрах).Так как...
Nastya35116
09.02.2022 23:00
Щоб зберегти відкритий файл з новим іменем необхідно...
pomogitmneaaaa
04.05.2021 15:12
В інтернеті відомості розміщенні...
izabella131313
20.10.2021 19:38
Чому дорівнює Х після виконання циклу. Вкажіть одну відповідь. x := 1; While x 5 do x := x*2 ; *...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Косинусы углов в треугольнике:
cosA=(b²+c²-a²)/(2bc); cosB=(a²+c²-b²)/(2ac); cosC=(a²+b²-c²)/(2ab)
var
a,b:real;
begin
Write('Введите a,b: ');
Read(a,b);
Write('P=',2*(a+b),', S=',a*b)
end.
Тестовое решение
Введите a,b: 12.2 8
P=40.4, S=97.6
var
a,b,c,cosA,cosB,cosC:real;
begin
Write('Введите a,b,c: ');
Read(a,b,c);
cosA:=(b*b+c*c-a*a)/(2*b*c);
cosB:=(a*a+c*c-b*b)/(2*a*c);
cosC:=(a*a+b*b-c*c)/(2*a*b);
Write('cosA=',cosA,', cosB=',cosB,', cosC=',cosC)
end.
Тестовое решение
Введите a,b,c: 15.3 8 14.2
cosA=0.138864436619718, cosB=0.855495719414526, cosC=0.393995098039216