В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ks1mak
Ks1mak
14.09.2020 17:30 •  Информатика

Составить программу паскаль.
В массиве С(25) найти количество кратных 3 элементов. Определите, есть ли в массиве Т(15) элементы кратные 7 найдите их сумму​

Показать ответ
Ответ:
вввв31
вввв31
21.06.2022 04:12
Вот задача для "троечников" с дополнительной оценкой:

program pr1;
uses
crt;

const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);

type
arr2 = array of integer;

var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;

begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;

writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.
0,0(0 оценок)
Ответ:
Sashalizer
Sashalizer
28.01.2021 10:27

1)Язык программирования определяет набор лексических, синтаксических и семантических правил, определяющих внешний вид программы и действия, которые выполнит исполнитель (обычно — ЭВМ) под её управлением.

2)

Существует большое множество языков программирования и придумывают различные разделять их на разные группы.

-Машинно-зависимые: к ним относится ассемблер, это один из языков с которого можно программировать микроконтроллеры и под каждый МК подбираются свои библиотеке и функции. Код на ассемблере будет зависеть от архитектуры контролера.

Машинно-независимые: это более высокоуровневые языки такие как Си, данные языки более медленные и занимают больше памяти. Но на данном этапе развития, Си вытесняет ассемблер так как его проще осваивать.

3)Трансля́тор — программа или техническое средство, выполняющее трансляцию программы. ... Трансля́ция програ́ммы — преобразование программы, представленной на одном из языков программирования, в программу на другом языке.

4)1) Разница в том, что компилятор преобразует код алгоритмического языка в исполняемый (байт-код либо нативный) код (в пределе - в машинные коды), в то время как интерпретатор самостоятельно распознаёт и выполняет построчно инструкции программного кода.

5)Любой транслятор выполняет следующие основные задачи: - анализирует транслируемую программу, в частности определяет, содержит ли она синтаксические ошибки; - генерирует выходную программу (ее часто называют объектной) на языке машинных команд; - распределяет память для объектной программы.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота