В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
tsukankova02mail
tsukankova02mail
05.11.2021 06:36 •  Информатика

Составить программу, печатающую числа в диапазоне от 45 до 369, которые не делятся на 6, но оканчиваются на цифру 6. нужно составить в pascal'e. нужно

Показать ответ
Ответ:
alins3
alins3
03.05.2023 18:30

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

var

 Chislo, Count, Summa, n: integer;

 

begin

 Summa := 0;

 Count := 0;

 readln(Chislo);

 while Chislo > 0 do

 begin

   n := Chislo mod 10;

   if odd(n) then  

   begin

     Summa := Summa + n;

     inc(Count);

   end;

   Chislo := Chislo div 10;

 end;

 writeln('Сумма  нечетных цифр числа: ', Summa);

 writeln('Кол-во нечетных цифр числа: ', Count);

 writeln('Среднее арифметическое  нечетных цифр: ', Summa / Count);

end.

Объяснение:

0,0(0 оценок)
Ответ:
HeZnAiKaxXx
HeZnAiKaxXx
07.09.2020 21:43
Const heigth = 10
Const width = 10

Sub Ìàêðîñ1()
    Dim Sum(heigth - 1, width - 1)
    Dim Product(heigth - 1, width - 1)
    
    For i = 0 To heigth - 1
        For j = 0 To width - 1
            Sum(i, j) = i + j
            Product(i, j) = i * j
        Next j
    Next i
    
    Call Show(Sum, 0, 0)
    Call Show(Product, 0, 12)
End Sub

Sub Show(ByRef m, dx, dy)
    For i = 0 To heigth - 1
        For j = 0 To width - 1
            ActiveSheet.Cells(dx + i + 1, dy + j + 1).Value = Hex(m(i, j))
        Next j
    Next i
End Sub
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота