В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Полиняша
Полиняша
20.01.2022 19:29 •  Информатика

Составить программу перевода мегабайт в килобайт на промежуток от 1 до 10 мб. в трёх циклах: for, while, repeat.

Показать ответ
Ответ:
денис1134
денис1134
29.03.2020 02:13

#include <iostream>

#include <string>

#include <cctype>

using namespace std;

signed main() {

 

string line, buff = "";

bool isPalindrome = true;

getline(cin, line);

for (int i = 0; i < line.size(); i++) {

 if (isalnum(line[i]))

  buff += line[i];

}

for (int i = 0; i < buff.size() / 2; ++i)

{

 if (buff[i] != buff[buff.size() - i - 1])

 {

  isPalindrome = false;

  break;

 }

}

if (isPalindrome)

 cout << "TRUE";

else

 cout << "FALSE";

return 0;

}

0,0(0 оценок)
Ответ:
LeadingLady
LeadingLady
16.03.2022 18:22

Відповідь:

public static void Main(string[] args){

  Console.WriteLine("Введите сообщение:");

  string t=Console.ReadLine();

  Console.WriteLine("Ваша строка до изменения:");

  Console.WriteLine(t);

  string[] s= t.Split(new char[]{' '},StringSplitOptions.RemoveEmptyEntries);

  for(int i=0;i<s.Length;i++){

   s[i] = (s[i].Substring(0,1).ToUpper()+s[i].Substring(1,s[i].Length-1));}

  Console.WriteLine("Ваша строка после изменения:");

  t=string.Join("",s);

  Console.WriteLine(t);

  Console.ReadKey(true);}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота