В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
didlok
didlok
04.02.2022 18:44 •  Информатика

Составить программу поиска больших чем соседние элементов массива l из 16 чисел. значения элементов массива рассчитать по формуле cosd/d,где d номер элемента массива.

Показать ответ
Ответ:
Vlada0904
Vlada0904
01.10.2020 14:14
VAR
   i: Integer;
   a: Array [1..16] of Real;
BEGIN
    For i := 1 to 16 do begin
        a[i] := Cos(i) / i;
        Writeln('L[',i,'] = ',a[i]); End;

    Writeln;
    For i := 2 to 15 do
        If (a[i] > a[i-1])and(a[i] > a[i+1]) then Writeln('L[',i,'] = ',a[i]);
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота