В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
timurtim1
timurtim1
27.02.2022 10:23 •  Информатика

Составить программу последовательность чисел кратных 3 из 77 элементов и находящую сумму всех чисел последовательности.щ

Показать ответ
Ответ:
Вано137
Вано137
10.10.2020 18:20

var a,k,s:integer;

begin

a:=3;

k:=1;

s:=0;

write('Последовательность ');

repeat

write(a,' ');

s:=s+a;

a:=a+3;

k:=k+1

until k>77;

writeln;

writeln('Сумма ',s)

end.

0,0(0 оценок)
Ответ:
Magia33
Magia33
10.10.2020 18:20

===== PascalABC.NET =====

begin

 SeqGen(77, i -> 3 * i, 1).Sum.Println

end.

Объяснение:

Поскольку не сказано, от какого числа последовательность начинается, договоримся, что это последовательность натуральных чисел и первым в ней является число 3. Фактически, это арифметическая прогрессия с разностью d = 3, содержащая 77 членов. Формула нахождения суммы такой последовательности общеизвестна, и создавать программу тут абсолютно нет надобности. Но уж настолько бедна фантазия авторов заданий, что они не в состоянии дать задачу, где действительно требуется программирование. Будем считать, что это задание демонстрирует случай, когда программы писать не нужно.

Итак сумма S = ( 2 · 3 + 3 · ( 77 - 1 ) ) · 77 / 2 = 9009.


Составить программу последовательность чисел кратных 3 из 77 элементов и находящую сумму всех чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота