Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Cvetochek554
03.10.2021 06:08 •
Информатика
Составить программу, позволяющую определить, имеет ли число, введённое с клавиатуры целый корень( через оператор if)
Показать ответ
Ответ:
Popyliarnich
05.10.2020 19:07
Var a:real;
begin readln(a);
if frac(sqrt(a))=0 then write('Да')
else write('Нет');
end.
0,0
(0 оценок)
Ответ:
ElenaComarova
05.10.2020 19:07
Program s;
var i : integer;
begin
readln(i)
if frac(sqrt(i)) = 0 then write('Yes.')
else write ('No.');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dog126
05.04.2022 23:22
1. Документ объёмом 8 Мбайт можно передать с одного компьютера на другой двумя А) сжать архиватором, передать архив по каналу связи, распаковать; Б) передать по каналу...
Ghdgfhs
14.03.2023 10:25
В операторі for...to...do крок зміни лічильника циклу завжди дорівнює:...
ванёк10062005
16.05.2021 06:58
Запиши алгоритм сбережения малюнкив у програми tux paint...
AsdZaKAsd
16.04.2020 21:20
1. составьте программу массива вещественных чисел yj? состоящего из 79 элементов. 2. найдите произведение всех элементов массива из 1. 3. составьте программу для решения...
bWn
16.04.2020 21:20
Напишите на paskal введите строку в которой записана сумма натуральных чисел например 1+25+3...
anastasialishcnastya
25.01.2021 23:28
Существует метод шифрования - шифрованмя с ключа. таким образом, результатом шифрования слова информация с учетом того, что за исходный алфавит был принят алфавит...
anastia15
29.09.2022 02:16
Категории функций для решения задач Все четырёхбуквенные слова, составленные из букв А, Л, Г, О, Р, И, Т, М записаны в алфавитном порядке и пронумерованы, начиная...
dgamal05
16.11.2020 10:45
Информатика составить план мероприятий и правил обеспечивающих информационную безопасность организации, ведущей закрытые научные исследования....
64bl9j8
17.12.2020 17:23
Попытайтесь заменить полную форму ветвления на два неполных ветвления: если слева стена то вправо иначе влево все Всегда ли можно сделать такую замену? 5. Можно ли...
57алес7т
19.05.2021 01:44
Если компьютеры не объединены в сеть, то как они могут обмени-ваться информацией?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin readln(a);
if frac(sqrt(a))=0 then write('Да')
else write('Нет');
end.
var i : integer;
begin
readln(i)
if frac(sqrt(i)) = 0 then write('Yes.')
else write ('No.');
end.