В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MilkyWay3355
MilkyWay3355
19.05.2023 03:25 •  Информатика

, Составить программу расчета конечной суммы 1+2+3+4+...+N. Полученный результат сравнить с контрольным значением по формуле N(N+1)/2. Количество слагаемых N вводится с клавиатуры.

Показать ответ
Ответ:
lizka12343
lizka12343
01.05.2021 06:45

Объяснение:

Участвуя в Событии, каждый игрок должен всегда соблюдать данные правила, а в случае, если игрок является Несовершеннолетним (определение приведено ниже), его родитель или законный опекун должен за выполнением Несовершеннолетним данных Правил, включая Правила поведения, указанные в разделе 8. Игрок (или его родитель или законный опекун в случае, если игрок является Несовершеннолетним) может принять данные Правила, щёлкнув по соответствующей кнопке в игровом клиенте, когда такая возможность будет предоставлена компанией Epic Games, Inc. (далее — Epic). Принимая участие в любой игре или матче в рамках События, игрок подтверждает, что он (или его родитель или законный опекун в случае, если игрок является Несовершеннолетним) соглашается с данными Правилами в соответствии с настоящим пунктом 1.2.

0,0(0 оценок)
Ответ:
dmitrijezhov20
dmitrijezhov20
23.10.2022 04:24

Объяснение:

a - массив;

sum - сумма элементов массива;

avrg - среднее значение.

Пример алгоритма решения задачи:

Заполняем массив (например, случайными числами).

Переменной sum изначально присваиваем значение 0.

Вычисляем сумму элементов, в цикле перебирая массив и добавляя значение каждого к переменной sum.

Находим среднее арифметическое, путем деления суммы на количество элементов (хранится в константе N).

Выводим на экран весь массив и найденное среднее значение. (Это не обязательно, но необходимо для удобства.)

Снова в цикле перебираем массив. Если очередной элемент больше среднего арифметического, то выводим этот элемент на экран.

const N = 10;

var

a: array[1..N] of integer;

i: byte;

avrg: real;

sum: integer;

begin

randomize;

for i:=1 to N do a[i]:=random(50)+1;

sum := 0;

for i:=1 to N do sum := sum + a[i];

avrg := sum/N;

// весь массив

for i:=1 to N do write(a[i]:3);

writeln;

writeln('Среднее арифм.: ',avrg:4:2

for i:=1 to N do if a[i]>avrg then write(a[i]:3);

writeln;

end.

Пример выполнения программы:

7 36 21 48 33 46 7 17 19 41

Среднее арифм.: 27.50

36 48 33 46 41

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота