В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
60026072anira
60026072anira
14.12.2022 19:08 •  Информатика

Составить программу, решающую следующую : дано число а. не пользуясь никакими другими операциями, кроме умножения, получить: за 3 операции.

Показать ответ
Ответ:
qq503
qq503
15.07.2020 21:52
\displaystyle x=a^8={((a^2)^2})^2={((a\times a)^2)}^2 \\ a_1:=(a\times a); \ a_2:=(a_1\times a_1); \ a_3:=(a_2\times a_2)


var
  x,a,b:longint;
 
begin
  a:=3;
  a:=a*a;
  a:=a*a;
  x:=a*a;
  Writeln('3 в степени 8 равно ',x)
end.

Тестовое решение:
3 в степени 8 равно 6561
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота