Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ankadudka
04.03.2022 07:56 •
Информатика
Составить программу, решающую следующую : возраст коли – x лет, а возраст миши – y лет. найти их средний возраст, а также определить, на сколько возраст одного мальчика отличается от возраста другого.
Показать ответ
Ответ:
280artur280
06.07.2020 12:04
#include <iostream>
using namespace std;
int main(){
int a,s,d,f;
setlocale(0,"");
cout<<endl<<"Введите возраст Коли:";
cin>>a;
cout<<endl<<"Введите возраст Миши:";
cin>>s;
if (a>s && a>0 && s>0) {
d=a-s; f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<s && a>0 && s>0) {
d=s-a; f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<0 || s<0) {
cout<<endl<<"Вы ввели отрицательное число"<<endl;
}
system ("pause");
return 0;}
0,0
(0 оценок)
Популярные вопросы: Информатика
NataliZotow
23.12.2020 07:38
с тестом по предмету Разработка посадочных страниц: Landing Pages . 16.Кнопки захвата в посадочных страницах - это элемент, который позволяет... а) мгновенно покинуть посадочную...
sashabibik777
17.03.2022 11:48
Нашел код на паскале но мне надо его на питоне, напишите или объясните как делать??? Var m,k:longint; Begin write( Введите M: );readln(m); While m 0 do Begin if m mod 10 mod 2 =...
кобра453
28.01.2020 12:00
Площадь полной поверхности цилиндра можно вычислить по формуле s=2пr(r+h), где r - радиус основания, h - высота цилиндра. пользуясь формулой, найдите h, если s = 4п, r=1....
lukycuk
28.01.2020 12:00
Скакой скоростью нужно бросить мяч вертикально вниз, чтобы он подпрыгнул на 5м выше того уровня, с которого его бросили? считать, что при отскоке потери скорости не происходит....
error404notfoud
28.01.2020 12:00
Основные составляющие оболочки а)озоновый слой,тропосфера b)верхний слой литосферы c)нижний слой атмосферы d)термосфера,тропосфера e)биосфера,экзосфера f)биосфера,гидросфера g)мезосфера,литосфера...
Jelinad
28.01.2020 12:00
Рассчитать массу оксида меди (ii), необходимого для растворения его в серной кислоте, при получении 16г сульфата меди....
kostyatyupa
28.01.2020 12:00
Дан прямоугольный треугольник.острый угол=50° .найдите угол образованный между биссектрисой и медианой....
rkrutoy
28.01.2020 12:00
Определите характер движения материальной точки, если ar = const...
Йщщ
28.01.2020 12:00
Что является примером моральной нормы? 1) надо мыть руки перед едой. 2) безбилетный проезд в общественном транспорте наказывается штрафом. 3) на новоселье первой в квартиру должна...
орп21
28.01.2020 12:00
Площадь осевого сечения цилиндра равна 108 см квадратных ,а его образующая в 3 раза меньше диаметра основания .найти объем этого цилиндра?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main(){
int a,s,d,f;
setlocale(0,"");
cout<<endl<<"Введите возраст Коли:";
cin>>a;
cout<<endl<<"Введите возраст Миши:";
cin>>s;
if (a>s && a>0 && s>0) {
d=a-s; f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<s && a>0 && s>0) {
d=s-a; f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<0 || s<0) {
cout<<endl<<"Вы ввели отрицательное число"<<endl;
}
system ("pause");
return 0;}