Составить программу, рисующую человека на карте беларуси рядом с областными , размер которого пропорционален количеству жителей.
ниже выведите гербы городов и численность населения. цвет текста выбирается в зависимости от численности населения: < 500 тыс. человек — зеленый, от 500 тыс. до 1000 тыс. человек — темно-красный, > 1000 тыс. человек — красный.
нужно сделать это в программе pascalabc
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-20,20); a.Println;
var (min,max):=(a.Min,a.Max);
Write('Номера минимальных элементов: ');
a.IndexesOf(t->t=min).Select(t->t+1).Println;
Write('Номера максимальных элементов: ');
a.IndexesOf(t->t=max).Select(t->t+1).Println;
a.Transform(t->t>0?min:t); a.Println
end.
Пример
6 -2 16 -1 -20 2 -9 0 16 15
Номера минимальных элементов: 5
Номера максимальных элементов: 3 9
-20 -2 -20 -1 -20 -20 -9 0 -20 -20
begin
// создание массива
var n:=ReadInteger('n=');
var a:=new integer[2*n];
for var i:=0 to n-1 do
(a[i],a[i+n]):=(i+1,5*(Sqr(i+1)+3));
a.Println;
// собственно решение
for var i:=0 to n-1 do
Writeln(a[i]:2,a[i+n]:8)
end.
Пример
n= 7
1 2 3 4 5 6 7 20 35 60 95 140 195 260
1 20
2 35
3 60
4 95
5 140
6 195
7 260
Console .WriteLine("Колис товара=" + n + " Цена товара = " + tovar + " стоимость покупки= "+ sum + " Оплата = " + oplata ); //Задача2 Console.WriteLine("Введите количество к км"); string r1 = Console.ReadLine(); double k = Convert.ToDouble(r1); double q = 1.609344; for (int i = 1; i < k + 1; i++) { Console.Write("км = " + i + " "); Console.WriteLine("миля = " + i / q); } Console.ReadKey();