В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ksapko
ksapko
09.05.2022 17:24 •  Информатика

Составить программу с использованием структур C++
Заданы координаты начала и конца двух векторов. Найти их скалярное произведение

Показать ответ
Ответ:
sdgsdgsdgsdgsdg228
sdgsdgsdgsdgsdg228
18.05.2020 01:29
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var k:=0;
  var n:=ReadInteger();
  var nmax:=0;
  while n<>0 do begin
    Inc(k);
    if n mod 10 = 0 then
      if n>nmax then nmax:=n;
    n:=ReadInteger()  
    end;
  var cntrl:=ReadInteger();
  Writeln('Получено ',k,' чисел');
  Writeln('Полученное контрольное значение: ',cntrl);
  Writeln('Вычисленное контрольное значение: ',nmax);
  if cntrl=nmax then Writeln('Контроль пройден')
  else Writeln('Контроль не пройден')
end.

Тестовое решение:
53
16
40
9
10
32
74
0
40
Получено 7 чисел
Полученное контрольное значение: 40
Вычисленное контрольное значение: 40
Контроль пройден
0,0(0 оценок)
Ответ:
Den4ikBLeT
Den4ikBLeT
22.12.2021 15:47
Человеку удобно хранить информацию в своей памяти И в памяти компьютера. Почему? Посмотрим на одну ситуацию с нескольких сторон. 
Мы находимся в школе. Друг внезапно попросил нас напомнить названия песен из коллекции. Если же у вас хорошая память, вы в любой момент можете дать информацию собеседнику или же другому средству. Иначе, вам нужно зайти в компьютер или же в иную технику, чтобы вспомнить данные. Но всё-таки есть много информации, которую необходимо хранить. В офисе, к примеру.  Поэтому здесь преимущество имеет компьютер. 
В итоге само удобство зависит от ситуации, случая.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота