В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу с которой вводится символ и определяется его код 2 последующий символа и 1 предыдущий

Показать ответ
Ответ:
diamiss45
diamiss45
05.02.2022 10:07
Var
a1,a2,b1,b2,c1,c2:integer;
begin
writeln('Координаты превой клетки');
writeln('введите номер столбца');
readln(a1);
writeln('введите номер строки');
readln(a2);
writeln('Координаты второй клетки');
writeln('введите номер столбца');
readln(b1);
writeln('введите номер строки');
readln(b2);
if ((a1 mod 2) <> 0) then
if ((a2 mod 2) <> 0) then c1:=0 else c1:=1;
if ((a1 mod 2) = 0) then
if ((a2 mod 2) <> 0) then c1:=1 else c1:=0;
if ((b1 mod 2) <> 0) then
if ((b2 mod 2) <> 0) then c2:=0 else c2:=1;
if ((b1 mod 2) = 0) then
if ((b2 mod 2) <> 0) then c2:=1 else c2:=0;
if c1=c2 then writeln('YES') else writeln('NO')
end.
0,0(0 оценок)
Ответ:
Ritochkа
Ritochkа
05.08.2022 12:02
Var
d:integer;
const
a=650;
b=1;
c=1000;
begin
write('Введите объём видеофайла в мегабайтах: ');
readln(d);
if d>a then write('Видеофайл не помещается на  носитель информации"А"!',#10) else
writeln('Памяти хватает для записи на носитель "А"! ',#10);
if d>b then write('Видеофайл не помещается на  носитель информации"B"!',#10) else
writeln('Памяти хватает для записи на носитель "B"! ',#10);
if d>c then write('Видеофайл не помещается на данный носитель информации"С"!',#10) else
writeln('Памяти хватает для записи на носитель "C"! ',#10);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота