В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Oksana1422
Oksana1422
13.12.2021 07:50 •  Информатика

составить программу с процедурой выводящую на экран 4 горизонтальные линии из символов ''*'':1 линия -7 символов,2 линия-19 символов,3 и 4 линия любое количество символов(<80,количество символов вводить с клавиатуры).Написать в паскале

Показать ответ
Ответ:
абвгдежзи7777
абвгдежзи7777
11.07.2021 15:58

Код программы:

procedure print(a, b:integer);

var i:integer;

begin

 for i:=1 to 7 do

   write('*');

 writeln();

  for i:=1 to 19 do

   write('*');

  writeln();

  for i:=1 to a do

   write('*');

   writeln();

  for i:=1 to b do

   write('*');

end;  

var a,b:integer;

begin

 writeln('Введите количество символов на 3 уровне(<80): ');

 readln(a);

 writeln('Введите количество символов на 4 уровне(<80): ');

 readln(b);

 if (a < 80) and (b < 80) then

     print(a,b)

 else

   writeln('Ошибка! Количество символов >= 80');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота