Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Зореслава
03.07.2020 15:09 •
Информатика
Составить программу согласно следующему условию. дан одномерный массив а из n элементов.осуществить операцию циклического сдвига на 1 элемент вправо. и блок схему бы еще
Показать ответ
Ответ:
Mercedess65amg
01.10.2020 21:26
На C++
#include <iostream.h>
const n=10;
void main()
{ int b,A[n]={1,2,3,4,5,6,7,8,9,0};
b=A[n-1];
for(int i=n-2;i>=0;i--) A[i+1]=A[i];
A[0]=b; for(i=0; i<n;i++)
cout<< A[i]<<','; }
0,0
(0 оценок)
Популярные вопросы: Информатика
ання2018
30.12.2020 17:19
Если средний у меня 2,8? Тогда у меня будет 3 или же 2? Тема говорится про СГО...
rishanaHD
01.04.2020 08:24
С клавиатуры вводится строка содержащая буквы и пробелы, посчитать количество слов в строке если между буквами в строке может стоять более одного пробела. Составить программу на...
remzoooo
15.01.2020 13:18
Визначте, який рядок S буде сформований у результаті виконання фрагмента програми при початковому S= : *var i, j: Integer; S: String;S:= ;For i:=1 To 2 do beginj:= 0.1;While j 1...
Рофлер
07.04.2021 14:10
Растровое изображение создается с использованием … примитивов a.линий b.пикселей c.символов Когда в растровом изображении появляется ступенчатый эффект… a.при уменьшении изображения...
Stukaneva
21.03.2023 02:20
Дядько важить N кг. Кожен день він випиває P л. Кожен літр добавляє йому X кг. Через скільки років його вага перевищить T кг.Написати скрипт на phytonДядя весит N кг. Каждый день...
ник41111
26.05.2020 05:24
1 Что будет выведено на экран после выполнения фрагмента программы: begin m:=5; If m 5 then y:=5+ m else y:=100-m; Writeln (y); end. 2 Что будет выведено на экран после выполнения...
arslanbaiguskap0c2gw
03.08.2022 00:46
Исполнитель чертёжник перемещается по координатной плоскости, оставляя след в виде линии. чертёжник может выполнять команду сместиться на (a, b)(где a, b - целые числа), перемещающую...
Panovamasha33
03.08.2022 00:46
Войдя в подземелье, аладдин увидел кодовый замок, кодом на котором должно быть семизначное число, все цифры которого различны. рядом с замком сидит электронный сфинкс, который может...
inessa2012
03.08.2022 00:46
1)определите при каких целых значениях переменной k логическая формула (к 1) и не (к 13) примет значение истина? 2) у мали несколько конфет. утверждение «у маши меньше 4 конфет...
кюд2
03.05.2022 10:41
Защита информации: электронные сертификаты и электронные подписи. где взять инфу. реферат 3-4 листа....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream.h>
const n=10;
void main()
{ int b,A[n]={1,2,3,4,5,6,7,8,9,0};
b=A[n-1];
for(int i=n-2;i>=0;i--) A[i+1]=A[i];
A[0]=b; for(i=0; i<n;i++)
cout<< A[i]<<','; }