В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
кисел5467
кисел5467
18.07.2021 00:40 •  Информатика

Составить программу сокращения одномерного числового массива путем удаления а) всех элементов с нулевыми значениями дополнительный массив использовать не ! , а то !

Показать ответ
Ответ:
машуля5552
машуля5552
07.06.2020 04:59

var

  a : array [1..100] of integer;

  i, next, n : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  next := 1;

  for i := 1 to n do

    if a[i] <> 0 then

    begin

      a[next] := a[i];

      next := next + 1;

    end;

  n := next - 1;

  for i := 1 to n do

    write (a[i], ' ');

end.

 

В результате работы в N будет лежать новая длина, а после массива - будет лежать всяий мусор (огрызок прежднего массива), но это неважно.

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота