В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
666642
666642
25.01.2020 15:22 •  Информатика

Составить программу суммирования натуральных чисел пока их сумма не превысит величину h. вывести на экран последнее слагаемое и сумму

Показать ответ
Ответ:
padafet2504
padafet2504
24.06.2020 21:44
Readln(n,h);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
0,0(0 оценок)
Ответ:
Эляна6
Эляна6
24.06.2020 21:44
Uses crt;
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота