В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
molinarudmanp01g00
molinarudmanp01g00
07.01.2020 19:39 •  Информатика

Составить программу "тест" для ответов "правильно" и "неправильно" на языке паскаль. должно быть задано три вопроса

Показать ответ
Ответ:
roma1918
roma1918
02.01.2021 17:36

ответ:

#include "stdafx.h"

#include

using namespace std;

struct complex // структура "хранения" комплексного числа

{ float re; // действительная часть

float im; // мнимая часть

};

void print( char * txt, complex x) // вывод комплексного числа

{

printf("%s=(%f,%fi)", txt, x.re, x.im);

return;

};

complex new_complex(float a, float b) // задать значение комплексному числу

{ complex temp;

temp.re=a;

temp.im=b;

return temp;

};

complex plus_complex(complex a, complex b) // сложить два комплексных чисел

{ complex temp;

temp.re=a.re+b.re;

temp.im=a.im+b.im;

return temp;

}

int main() // простая тестовая программа

{

complex z;

printf( "vvedite re и im 1 chisla: ");

cin > > z.re > > z.im;

print( "z", z); printf("\n");

complex q;

printf( "vvedite re и im 2 chisla: ");

cin > > q.re > > q.im;

print("q", q); printf("\n");

complex sum;

sum=plus_complex(z,q);

print("q+z", sum); printf("\n");

return 0;

}

0

0,0(0 оценок)
Ответ:
kinderlolo19999
kinderlolo19999
03.07.2021 09:06
Судя по полагается то ,  что они играли не зависимо за какую именно .  посчитаем сколько вообще было встреч , у команды первой лиги команд в 2 раза больше так как    .  посчитаем отдельно каждую встречу внутри команд ,и между разными .    по первой лиги это число сочетаний по высшей лиги это число сочетаний а между собой очевидно в сумме встреч.  если не было ничьи то очевидно одно из двух  1) либо   команда проиграет  2) либо команда выиграет  число выигрышей и проигрышей будет равна количеству сыгранных игр . то есть если всего у команда  побед то  пусть количество выигрышей команды первой лиги равна  , то другой что бы число делилось на 8 , очевидно что n либо само должно быть кратно 8 , либо     должно делится на 8 , подходит   при нем все выполняется 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота