В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ино7
ино7
03.05.2022 21:24 •  Информатика

Составить программу, в которой необходимо напечатать заданное слово в одной строке с разрядкой (пробел после каждой буквы)

Показать ответ
Ответ:
cghjy6655
cghjy6655
18.02.2022 01:10

#include <iostream>

#include <string>

int main()

{

   std::string str;

   std::cin>>str;

   for (char c : str) {

       std::cout << c << " ";

   }

}

0,0(0 оценок)
Ответ:
nyatteloiv
nyatteloiv
18.02.2022 01:10

Самый простой с применением метода replace и cреза двух ненужных пробелов в начале и в конце. (фото 1)

Другой без специальных строковых методов. (фото 2)


Составить программу, в которой необходимо напечатать заданное слово в одной строке с разрядкой (проб
Составить программу, в которой необходимо напечатать заданное слово в одной строке с разрядкой (проб
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота