В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Emptу
Emptу
25.06.2020 14:06 •  Информатика

Составить программу в pascal, которая в тексте после каждой буквы вставляет заданный символ (с стандартных процедур)

Показать ответ
Ответ:
PUPOK2101
PUPOK2101
07.10.2020 08:11
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите текст:');
  var c:=ReadlnChar('Введите букву для вставки');
  var s1:='';
  for var i:=1 to s.Length do begin
    s1+=s[i];
    if s[i]<>' 'then s1+=c
    end;
  Writeln(s1)
end.

Пример
Введите текст: Привет паскалю!
Введите букву для вставки Ы
ПЫрЫиЫвЫеЫтЫ пЫаЫсЫкЫаЫлЫюЫ!Ы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота