В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу в pascal, найти сумму произведений 1 и 2, 3 и 4, и тд элементов массива состоящего из 10 значений. заранее !

Показать ответ
Ответ:
doncov2001
doncov2001
07.10.2020 18:04
Var
a:array[1..10] of integer;
i, ans:integer;
begin
  Writeln('Введите массив из 10ти элементов: ');
  for i:= 1 to 10 do
    read(a[i]);
  i:= 1; ans:= 0;
  while i < 10 do
    begin
      ans:= ans + a[i] * a[i+1];
      i:= i + 2;
    end;
  Writeln(ans);  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота