В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
superschool1
superschool1
17.04.2023 00:48 •  Информатика

Составить программу в pascal! задана последовательность слов. определить частоту вхождения каждого из слов в последовательность.

Показать ответ
Ответ:
Kr1c
Kr1c
03.10.2020 02:27
Var   s,r,k: string;
         j: integer;
begin
  write('строка:  ');  readln(s);
    foreach k in s.Split(' ').Distinct do
    begin
      j:=0;
      foreach r in s.Split(' ') do
      if r=k then j:=j+1;
      writeln('слово   ','"',k,'"','   встречается ',j,' раз');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота