В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
di23di
di23di
29.07.2020 04:10 •  Информатика

Составить программу в Паскаль. 9 класс В массиве случайных чисел в диапазоне от 2 до 5 определите каких чисел больше. В ответ выведите количество этих чисел.

Показать ответ
Ответ:
gxgvxf
gxgvxf
22.05.2022 07:25

Алгоритм приготовления гречневой каши обыкновенной. )

1. Поставить кастрюлю на стол

2. поставить стакан на стол

3. Поставить упаковку с гречкой на стол

4. поставить графин с водой на стол

5. насыпать полный стакан гречки

6. пересыпать гечку в кастрюлю

7. выполнить 2 раза

  7.1 налить полный стакан воды

  7.2. перелить стакан воды в кастрюлю

8. зажечь огонь на плите

9. поставить кастрюлю с гречкой на огонь

10. Выполнять пока не закипит

   10.1. Ждать

11. Посолить

12. Накрыть крышкой кастрюлю

13. Пока не мин

  13.1. Ждать

14. Выключить огонь.

 

Гречка готова. )

 
0,0(0 оценок)
Ответ:
jihope69
jihope69
23.03.2021 21:17

var

  b:array[1..100] of integer;

  i, count, n:integer;

begin

  randomize;

  write('n = '); readln(n);

  for i := 1 to n do

  begin

    b[i] := random(51) - 25;

    writeln('b[', i, '] = ', b[i]);

  end;

  writeln;

  count := 0;

  for i := 1 to n do

    if b[i] >= 0 then

    begin

      writeln('b[', i, '] = ', b[i], ' >= 0');

      inc(count);

    end;

  writeln('Count = ', count);

end.

 

 

 

// вторая программа

 

const

  n = 20;

var

  a:array[1..n] of integer;

  i, k:integer;

begin

  randomize;

  writeln('Исходный массив: ');

  for i := 1 to n do

  begin

    a[i] := random(51);

    write(a[i], ' ');

  end; 

  writeln;

  

  write('k = '); readln(k);

  if (k > n) or (k  < 1) then

  begin

    writeln('элемента с таким индексом нет');

    readln;

    Exit;

  end;

  for i := k to n - 1 do

    a[i] := a[i + 1];

  a[n] := 0;

  writeln('Измененный массив:');

  for i := 1 to n - 1 do

    write(a[i], ' ');

  readln;

  writeln;

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота