В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
curtain
curtain
05.06.2023 13:22 •  Информатика

Составить программу в паскаль абс и блок-схему: в заданной целочисленной квадратной матрице заменить нулями минимальные элементы каждой строки

Показать ответ
Ответ:
adadurovf
adadurovf
03.10.2020 23:47
//PascalABC.NET 3.2 сборка 1318

Const
 n=3;
 m=2;

Var
  ma:array[1..n,1..m] of integer;
  i,j,min:integer;
begin
for i:=1 to n do
begin
min:=integer.MaxValue;
  for j:=1 to m do
    begin
      readln(ma[i,j]);
      if ma[i,j]<min then min:=ma[i,j];
    end;
  for j:=1 to m do
    if ma[i,j]=min then ma[i,j]:=0;
end;
writeln('Final matrix:');
for i:=1 to n do
begin
  for j:=1 to m do
    write(ma[i,j]:4);
writeln;
end;
end.
Составить программу в паскаль абс и блок-схему: в заданной целочисленной квадратной матрице заменить
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота