В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
razebal
razebal
25.05.2020 07:07 •  Информатика

Составить программу (в Паскаль через вложенные циклы )для графического изображения делимости чисел от 1 до n. В каждой строке надо напечатать очередное число и столько символов “+”, сколько делителей у этого числа. Например, если n = 4, то на экране должно быть напечатано:
1+
2++
3++
4+++

Показать ответ
Ответ:
номе498
номе498
17.08.2020 19:53

Код на Pascal выводит точно то, что требуешь )). Напомню лишь, не забудь про отступы, когда будешь писать/копировать код. Удачи! )):

var i,j,m,n: integer;

pl{,i_s}: string;

begin

   pl:= '';

   writeln('Enter n: n = ');

   readln(n);

   for i:= 1 to n do

   begin

       for j:= 1 to i do

       begin

           pl:= pl + '+';

       end;

   //i_s:= string(i);

   writeln(i{_s},' ',pl);

   pl:= '';

   end;

end.


Составить программу (в Паскаль через вложенные циклы )для графического изображения делимости чисел о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота