В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
annachanskp06yi3
annachanskp06yi3
30.07.2021 05:25 •  Информатика

Составить программу в паскаль: даны 4 числа,выделить целые части и найти среднее арифметическое этих чисел.

Показать ответ
Ответ:
kapikyna
kapikyna
20.07.2020 19:30
Var
  i:integer;
  a,c:real;
begin
  c:=0;
  Writeln('Введите четыре произвольных числа');
  for i:=1 to 4 do
  begin
    Read(a); c:=c+Int(a)
  end;
  c:=c/4;
  Writeln('Среднее арифметическое равно ',c)
end.

Тестовое решение:
Введите четыре произвольных числа
4.7 5.03 4.12 5
Среднее арифметическое равно 4.5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота