Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
крис903
06.02.2020 04:32 •
Информатика
Составить программу в паскаль. вычислить и запомнить значения функции yi=x , если xi< 0 yi=0 , если xi=0 -1 , если xi≤0 где xi - элементы массива из 20 элементов
Показать ответ
Ответ:
Вика310387
16.07.2020 21:06
# include <bits\stdc++.h>
using namespace std;
int main()
{
int x[20], y[20];
int i, n;
cin >> n;
for(i = 1; i <= n; ++i)
cin >> x[i] >> y[i];
if(x[i] > 0)
y[i] = x[i];
if(y[i] == 0)
x[i] = 0;
if(x[i] <= 0)
puts('-1');
else
cout << x[i] << ' ' << y[i];
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
146727
14.01.2023 20:51
Жесткий диск пусть имеет 160 гб сколько книг в каждой из которой состоит 256 стр. на каждой странице 128 строк,в каждой строке 64 символа можно записать на такой жесткий диск каждый...
Bashirov12
02.10.2020 10:33
Из 2-й в 10-ю 10110011=? 100011101=? 10101110101=? информатика 8-клас...
Слон145
17.04.2020 13:43
1. информационный объём сообщения длиной в 120 символа составляет 75 байт. определите, из какого максимального количества символов может состоять алфавит языка, на котором написано...
aleksapopov1
19.12.2021 03:00
Как сделать такой же текст в Word art? Именно надпись форматирование текста...
Marshall123
13.09.2021 22:06
Решить уравнение: (5x+2)^4=(3x+4)^4...
anna1919191
13.09.2021 22:06
Решите уравнение: 1)2x+17=22+3x; 2)18+3x=x+14; 3)25-4x+12-5x; 4)13x+27=16x+4,5; 5)21x+45=17+14x; 6)13x+70=2x+15...
melenam08041974
13.09.2021 22:06
Составить предложения со словосочетаниями.геаграфичная карта,цикавае апавяданне....
VIXXX
13.09.2021 22:06
При жирафа к размножению и распространению...
llggvvjvhh
13.09.2021 22:06
Однородный диск радиусом r подвешен за край. чему равна частота его малых колебаний относительно точки подвеса....
Masha20468
13.09.2021 22:06
Диалог на тему знакомство с неполными предложениями ( только не совсем короткие предложения)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
int x[20], y[20];
int i, n;
cin >> n;
for(i = 1; i <= n; ++i)
cin >> x[i] >> y[i];
if(x[i] > 0)
y[i] = x[i];
if(y[i] == 0)
x[i] = 0;
if(x[i] <= 0)
puts('-1');
else
cout << x[i] << ' ' << y[i];
return 0;
}