В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Вовка753
Вовка753
28.09.2022 10:55 •  Информатика

Составить программу в паскале 1)игровой автомат выдает целые числа от 0 до 10 если выпадает 7, то выйгрыш. 2)игровой автомат получает 3 случайных числа от 0 до 10, если числа совпадут, то выйгрыш 3)вывести на экран 10 случайных чисел от 0 до 100, и определить сколько из них чётных надо к завтрашнему дню, заранее .

Показать ответ
Ответ:
LunaLovegood28
LunaLovegood28
05.07.2020 19:46
1)
var
i:integer;
begin
randomize;
i:=random(11);
writeln('vipalo chislo: ',i)
;if (i = 7) then writeln('POBEDA!') else writeln('Pobrobyite eshe!');
end.

2)
var
i_1,i_2,i_3:integer;
begin
randomize;
i_1:=random(11);
i_2:=random(11);
i_3:=random(11);
writeln('vipalo chislа: ',i_1,' ',i_2,' ',i_3);

if (i_1 = i_2)and(i_2 = i_3) then writeln('Winer!') else writeln('Sorry,try again!')
end.
3) var  i, k, z: integer;
begin 
 randomize; 
k := 0; 
for i := 1 to 10 do  
 begin   
 z := random(101); 
  write(' ', z); 
   if odd(z) then k := k + 1; 
 end; 
 writeln; 
 writeln('Kolichestvo chetnysh: ', k);
  end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота