В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
SteveDog86
SteveDog86
01.07.2022 21:29 •  Информатика

Составить программу в паскале как изменяетс ястепень найти сумму 2^3+ 2^5 + …+ 2^9

Показать ответ
Ответ:
Вывыия
Вывыия
27.05.2020 20:05

uses crt;
function step(n:integer):integer;
var p:integer;
begin
p:=2;
repeat
p:=p*2;
n:=n-1;
until n=1;
step:=p;
end;

var
a,sum,n:integer;
begin
n:=3;
repeat
sum:=sum+step(n);
n:=n+2;
until n>9;
write(sum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота