В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
гребок
гребок
10.12.2022 16:15 •  Информатика

Составить программу в паскале которая ,находит среднее арифметическое натуральных чисел, меньших 200 и кратных 7.

Показать ответ
Ответ:
oksankalahutina5
oksankalahutina5
15.10.2020 11:00

begin

 Range(7, 200, 7).Average().Print();

end.

//PascalABC.NET 3.5.X

0,0(0 оценок)
Ответ:
ikstar
ikstar
15.10.2020 11:00
begin(1..199).Where(x -> x mod 7 = 0).Average.Printend.

или

var i,s,n: integer;beginwhile i+7<200 dobegini := i + 7;s := s + i;n := n + 1;end;write(s/n);end.

Пример работы:


Составить программу в паскале которая ,находит среднее арифметическое натуральных чисел, меньших 200
Составить программу в паскале которая ,находит среднее арифметическое натуральных чисел, меньших 200
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота