В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
artem24322004
artem24322004
20.07.2021 18:09 •  Информатика

составить программу в Паскале


Ресторан закупает ежедневно Z1 кг масла по 188,50 р/кг, Z2 кг
сметаны по 95 р/кг, Z3 кг сливок по 104,50 р/кг. Цена товара
определяется командой присваивания, количество – командой ввода.
Программа должна определить суммы, необходимые для покупки
отдельных товаров и общую сумму.

Показать ответ
Ответ:
visnevsk
visnevsk
12.10.2020 08:59

var

 sum, a, b, c: real;

begin

 Write('Введите количество масла в кг.: ');

 Read(a);

 Write('Введите количество сметаны в кг.: ');

 Read(b);

 Write('Введите количество сливок в кг.: ');

 Read(c);

 sum := a * 188.5;

 Writeln('За ', a, 'кг. масла, получится: ', sum, 'р.');

 sum := b * 95;

 Writeln('За ', b, 'кг. сметаны, получится: ', sum, 'р.');

 sum := c * 104.5;

 Writeln('За ', c, 'кг. сливок, получится: ', sum, 'р.');

 Writeln('Общая сумма: ', (a * 188.5) + (b * 95) + (104.5), 'р.');

end.

Тестовое решение:

Введите количество масла в кг.: 6

Введите количество сметаны в кг.: 4

Введите количество сливок в кг.: 2

За 6кг. масла, получится: 1131р.

За 4кг. сметаны, получится: 380р.

За 2кг. сливок, получится: 209р.

Общая сумма: 1615.5р.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота