В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу в паскале с использованием циклических операторов: среди всех чисел,меньших к ( к< =999) указать те, сумма цифр которых равна даномучислу n

Показать ответ
Ответ:
ustinlox
ustinlox
01.10.2020 23:02
function sum(i, n: integer): boolean;
var
  a, b: integer;
begin
  a := i;
  repeat
    b := b + a mod 10;
    a := a div 10;
  until (a = 0);
  sum := (b = n);
end;

var
  n, i, k: integer;
begin
  readln(n, k);
  for i := 1 to k do
    if sum(i, n) then
      writeln(i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота