В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу в паскале: в компьютер вводятся числа числа от 1 до 9. нужно посчитать количество чётных и нечётных.

Показать ответ
Ответ:
ротилуся1
ротилуся1
31.08.2020 13:43
Program help;
uses Crt;
var a,cot,cpo:integer;
begin
ot:=0;po:=0;cot:=0;cpo:=0
repeat
writeln('Число: ');
readln(a);
if a<0 then begin ot:=ot+a; inc(cot);end else
if a>0 then begin po:=po+a; inc(cpo); end else
if a=0 then begin
writeln('Кол-во положительных чисел: ',cpo);
writeln('Кол-во отрицательных чисел: ',cot);
end;
until a=0;
readln;
end
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота