В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
bobmarli436
bobmarli436
15.03.2020 05:29 •  Информатика

Составить программу в Python определить сколько единиц в данном числе, напомним, что еденица - это послелняя цифра в числе ​

Показать ответ
Ответ:
Savosin229
Savosin229
27.02.2020 00:47
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  case ReadInteger('Номер месяца (1-12):') of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.

Вариант "для школьников"
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
var n:integer;
begin
  Write('Номер месяца (1-12): '); Read(n);
  case n of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.
0,0(0 оценок)
Ответ:
миснайс
миснайс
26.04.2022 11:37
//"Школьный" вариант
//Pascal ABC.NET 3.1 сборка 1256

Const
 n=10;

 Var
 ar:array[1..n] of integer;
 i,max,min:integer;
b:boolean;
begin
randomize;
b:=false;
max:=integer.MinValue;
min:=integer.MaxValue;
writeln('Array:');
for i:=1 to n do
 begin
  ar[i]:=random(-100,100);
  if (ar[i]>max) and not(odd(ar[i])) and (ar[i]>0) then
  begin
   max:=ar[i];
   b:=true;
  end;
  if (ar[i]<min) and not(odd(ar[i])) and (ar[i]>0) then
  begin
   min:=ar[i];
   b:=true;
  end;
  write(ar[i]:4);
 end;
writeln;
if b=false then writeln('Нет удовлетворяющих условиям чисел') else
 begin
  writeln('Max=',max);
  writeln('Min=',min);
 end;
end.

Пример работы программы:
Array:
  98  60 -41 -88  63 -81 -77 -96 -18  51
Max=98
Min=60
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота