В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
NikaEvgen
NikaEvgen
28.03.2022 16:00 •  Информатика

Составить программу в с++, печатающую значение true , если указанное высказывание является истинным , и false в противном случае : числа a и b выражают длины катетов одного прямоугольного треугольника , а c и d - другого . эти треугольники являются подобными . на языке с ++

Показать ответ
Ответ:
Filipok220
Filipok220
20.07.2020 18:51
#include <iostream>
using namespace std;

int main()
{
    double a,b,c,d;
    cout << "Enter 1st-triangle catheti here: " << endl;
    cin >> a >> b;
    cout << "Enter 2nd-triangle catheti here: " << endl;
    cin >> c >> d;

    bool podobie = ((a/c == b/d) || (a/d == b/c));

    cout << boolalpha;
    cout << podobie;
    
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота