В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
valeria232425
valeria232425
07.05.2022 18:38 •  Информатика

Составить программу, вводящую массив с клавиатуры и сортирующую его по возрастанию. Вывести отсортированный массив в строку через точку с запятой.

Показать ответ
Ответ:
3848390
3848390
03.02.2023 23:21

.

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   long sum = 0;

   int a;

   cout << "Введите a" << endl;

   cin >> a;

   if (a > 500)

   {

       cout << "а > 500" << endl;

   }

   else

   {

       sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;

       cout << sum;

   }

}

2.

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   double average = (1 + 1000) / 2.;

   cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;

}

3

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   int a = 0, b = 0;

   cout << "Введите границы диапазона" << endl;

   cin >> a >> b;

   cout << "Все числа:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           cout << i << endl;

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           cout << i << endl;

       }

   }

   cout << "Чётные числа:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           if (i % 2 == 0)

           {

               cout << i << endl;

           }

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           if (i % 2 == 0)

           {

               cout << i << endl;

           }

       }

   }

   cout << "Нечётные числа:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           if (i % 2 != 0)

           {

               cout << i << endl;

           }

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           if (i % 2 != 0)

           {

               cout << i << endl;

           }

       }

   }

   cout << "Числа, кратные 7:" << endl;

   if (a <= b)

   {

       for (int i = a; i <= b; i++)

       {

           if (i % 7 == 0)

           {

               cout << i << endl;

           }

       }

   }

   else

   {

       for (int i = b; i < a; i++)

       {

           if (i % 7 == 0)

           {

               cout << i << endl;

           }

       }

   }

}

4.

#include <iostream>

using namespace std;

void main()

{

   //задаём русский язык для консоли

   setlocale(LC_ALL, "Russian");

   int a = 0, sum = 0;

   cout << "Введите числа" << endl;

   while (true)

   {

       cin >> a;

       if (a == 0)

       {

           break;

       }

       sum += a;

   }

   cout << "Сумма =" << sum << endl;

0,0(0 оценок)
Ответ:
Lesya2601
Lesya2601
20.09.2020 02:03

Один или несколько компонентов программы Avast Antivirus, в частности экраны или брандмауэр, могут перейти в состояние Остановлено, при этом их будет невозможно запустить вручную через интерфейс программы Avast Antivirus.

Эти проблемы, как правило, вызваны ограниченными или несовместимыми правами записи на диск, в системные папки или реестр Windows, что мешает программе установки Avast установить, обновить, удалить или перезаписать некоторые программные файлы или записи реестра. Отсутствие каких-либо из этих файлов и записей или их повреждение может привести к неправильному функционированию программы Avast Antivirus или ее отдельных компонентов.

Некоторые из действий, описанных в этой статье, могут потребовать углубленных технических навыков, но их необходимо выполнить, чтобы полностью устранить проблемы с компонентами Avast Antivirus и предотвратить их возникновение в будущем.

Объяснение:

Прежде чем приступить к устранению неисправностей, убедитесь, что вы вошли в систему Windows как пользователь с правами администратора, а все другие программы в ОС Windows закрыты. Более подробную информацию можно найти в статье ниже.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота