В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sanay06
sanay06
04.01.2022 07:00 •  Информатика

Составить программу вычисления, a - сумма положительных элементов массива; b - количество отрицательных элементов массива; c - произведение элементов массива с нечетными номерами. полученные значения элементов а,b,c,w вывести на печать. паскаль!

Показать ответ
Ответ:
999Fox999
999Fox999
10.09.2020 23:56

const n=10;

var m:array [1..n] of integer;

i,A,B,C:integer;

begin

C:=1;

write('Массив: ');

for i:=1 to n do

begin

m[i]:=random(41)-20;

if m[i] > 0 then A:=A+m[i];

if m[i] < 0 then B:=B+1;

if i mod 2 <> 0 then C:=C*m[i];

write(m[i],'  ')

end;

writeln;

writeln('Сумма положительных элементов: ',A);

writeln('Количество отрицательных элементов: ',B);

writeln('Произведение элементов массива с нечетными номерами: ',C);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота