В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
demoplus1
demoplus1
07.07.2020 21:12 •  Информатика

Составить программу вычисления длины окружности, если известен радиус: С=2пr
=15
c=2*3 14*r
print(Длина окружности:", с)​

Показать ответ
Ответ:
Nataliaroy
Nataliaroy
18.06.2022 18:33
        private string fuction(string a,string b)        {
            char[] massa = a.ToCharArray();            char[] massb = b.ToCharArray();            foreach(char itema in massa)            {                foreach(char itemb in massb)                {                    if(itema == itemb)                    {                        break;                    }                    else                    {                        a += itema.ToString();                        break;                    }                }            }            return a;        }
0,0(0 оценок)
Ответ:
Патрисия2000
Патрисия2000
18.06.2022 18:33
В программе буквы добавляются по алфавиту без повторений.
var s1,s2:string;
function F(var a,b:string):boolean;
var m:set of char; i:integer; c:char;
begin
 m:=[];
 for i:=1 to length(a) do
  if pos(a[i],b)=0 then m:=m+[a[i]];
 for c:=chr(32) to chr(255) do
  if c in m then a:=a+c;
 if m=[] then f:=false else f:=true;
end;
begin
writeln('Введите строку 1:');
readln(s1);
writeln('Введите строку 2:');
readln(s2);
if f(s1,s2)
 then writeln('Новая строка: ',s1) else writeln('Строка не изменилась ');end.

Пример:
Введите строку 1:
program
Введите строку 2:
procedure
Новая строка: programagm
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота