В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
poly77
poly77
01.01.2022 19:46 •  Информатика

Составить программу вычисления для заданных значений х,у,z арифметического выражения:

Показать ответ
Ответ:
alins3
alins3
25.07.2022 08:56
var  mas1, mas2: array[0..9] of integer;  t, k, i, j: integer; 
begin  
readln(t);  
readln(k);  
for j := 0 to 1 do  begin   
      if (j = 1) then writeln();        
                 for i := 0 to 9 do    begin      
                          if(j = 0) then begin       
                                  mas1[i] := random(100);        
                                    write(mas1[i], ' ');       
                                    if mas1[i] > t Then mas1[i] := mas1[i] + 4;      
                              end      
                            else 
                               begin       
                                      mas2[i] := random(100);        
                                      write(mas2[i], ' ');       
                                       if mas2[i] > 10 * K Then         
                                            mas2[i] := mas2[i] + K;      
                                end;    
                       end;       
                  for i := 0 to 9 do     
                         if (j = 0) then 
                               write(mas1[i]) 
                        else 
                                write(mas2[i]);    
               writeln();  
           end;  
readln();
end.

))
0,0(0 оценок)
Ответ:
катя10467743
катя10467743
25.07.2022 08:56
Uses Crt;
const
  n=10;
var
  a,b:array[1..n] of integer;
  i,k,t:integer;
begin
  ClrScr;
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(50);
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    b[i]:=Random(50);
    Write(b[i],' ')
    end;
  Writeln;
  Write('k t='); Read(k,t);
  for i:=1 to n do begin
    if a[i]>t then a[i]:=a[i]+4;
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    if b[i]>10*k then b[i]:=b[i]+k;
    Write(b[i],' ')
    end;
  Readkey
end.

Тестовое решение:
1 6 23 12 47 1 44 24 6 18
31 30 30 29 0 3 43 32 46 21
k t=2 20
1 6 27 12 51 1 48 28 6 18
33 32 32 31 0 3 45 34 48 23
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота