В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nikita2455
nikita2455
18.05.2020 19:48 •  Информатика

Составить программу вычисления функции на паскале ABC.NET на заданных промежутках и с заданным шагом h.

используя var, const, writeln и тд, всё что нужно. чтобы было понятно


Составить программу вычисления функции на паскале ABC.NET на заданных промежутках и с заданным шаго

Показать ответ
Ответ:
MiraQeen
MiraQeen
29.04.2021 00:43
Var a:array of array of integer;
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;

writeln('Matrix A:');   //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
 writeln;
  for j:=1 to n do
   begin;
    a[i,j]:=random(10);
    write(a[i,j]:4);
   end;
 end;
writeln;

writeln('Matrix C:'); //аналогично
for i:=1 to n do
 begin;
 writeln;
  for j:=1 to n do
   begin;
    c[i,j]:=random(10);
    write(c[i,j]:4);
   end;
 end;

for i:=1 to n do     //сохраняем матрицу C для транспонации
  for j:=1 to n do
    ma[i,j]:=c[i,j];
    writeln;

writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     c[i,j]:=ma[j,i];
     write(c[i,j]:4);
    end;
 end;

writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
     write(ma[i,j]:4);
    end;
 end;
end.
0,0(0 оценок)
Ответ:
ffffffffff444
ffffffffff444
09.06.2021 08:19

Объяснение:

1. Пронумеруем разряды:

3-й разряд - 4;

2-й разряд - 1;

1-й разряд - 5;

0-й разряд - 3.

4153₈=4·8³+1·8²+5·8¹+3·8⁰

2. 4153₈=4·8³+1·8²+5·8¹+3·8⁰=2048+16+40+3=2155₁₀

3. 125/8=15 (5)

15/8=1 (7)

(1)

125₁₀=175₈

4. Пронумеруем разряды:

2-й разряд - A;

1-й разряд - 6;

0-й разряд - E;

A6E₁₆=(10)(6)(14)=10·16²+6·16¹+14·16⁰

5. A6E₁₆=10·16²+6·16¹+14·16⁰=2560+96+14=2670₁₀

6. 350/16=21 (14=E)

21/16=1 (5)

(1)

350₁₀=15E₁₆

7. 247/2=123 (1)

123/2=61 (1)

61/2=30 (1)

30/2=15 (0)

15/2=7 (1)

7/2=3 (1)

3/2=1 (1)

(1)

247₁₀=11110111₂

247/8=30 (7)

30/8=3 (6)

(3)

247₁₀=367₈

247/16=7 (15=F)

(7)

247₁₀=7F₁₆

Получившиеся числа между собой равны, так как имеют одинаковое число в десятичной системе счисления.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота